JonDoBrowser

Ideen zu allem, was nützlich wäre. Vorschläge und Tipps zur JonDonym-Programmierung.
cane

Re: JonDoBrowser

Post by cane » Fri Dec 20, 2013 20:08

Beim Versuch den Browser zu öffnen erscheint folgende Nachricht:
Ich bin ratlos bezüglich des JonDoBrowser. Ich verstehe dieses MacOS nicht. :evil:
JonDoFox für Mac < als 10.9. Läuft dies auf 32-bit Rechnern?
Damit kann es wirklich keine Probleme geben. Sie brauchen einen aktuellen(!) Firefox, dann können Sie den JonDoFox installieren.

Das JonDoFox-Profil enthält keinen Binär-Code, das läuft auf allen Plattformen, für die es einen Firefox gibt.

Die Installation ist bei der legacy-Version für Mac < als 10.9. aber nicht sehr hübsch, Sie müssen ein Terminal öffnen und drei Befehle auf der Kommandozeile eintippen (Linux-like), siehe: https://www.anonym-surfen.de/help/insta ... l#macos108

Woody
Posts: 106
Joined: Sat Jun 02, 2012 23:02

Re: JonDoBrowser

Post by Woody » Fri Dec 20, 2013 20:55

Hi,

ich habe den JonDoBrowser 0.12 auf eine Mac (Lion) sowie das JonDoFox-Profil installiert.

Nun beobachte ich folgendes Verhalten: Öffen ich den JonDoBrowser "direkt", habe ich eine deutsche Version (24.2.0).

Verwende ich ein Drittprogramm (bspw. KeePassX), um ins Internet zu gelangen, öffent sich ein englischsprachiger Profilmanager, in dem ich den JonDoBrowser wählen kann. Dieser ist dann allerdings auch in Englisch.

Worn kann dies liegen und vor allem wie kann ich den "englischen" JonDoBrowser" wieder entfernen (ich bin mir zudem nicht bewußt, diesen installiert zu haben).

VG Woody

cane

Re: JonDoBrowser

Post by cane » Fri Dec 20, 2013 21:22

in dem ich den JonDoBrowser wählen kann
Sie können wahrscheinlich den "JonDoFox" im Profilmanager wählen, nicht den "JonDoBrowser".

Ich vermute mal:

- Sie haben einen Firefox (englisch) installiert mit dem JonDoFox Profil
- Sie haben parallel einen JonDoBrowser (deutsch) installiert.

Wenn ein Drittprogramm (bspw. KeePassX) den Standard-Browser starten will, dann wird das Kommando "firefox" abgefeuert, der englische Firefox startet und fragt, welches Profil genutzt werden soll (vermutlich "default" oder "JonDoFox")

Wenn Sie den deutschen JonDoBrowser direkt starten, dann starten Sie einen ganz anderen Browser, der nicht als Standardbrowser eingerichtet werden kann und der auch keine Webseiten beim Aufruf von Drittprogrammen öffnen kann. Der "JonDoBrowser" kann nicht von KeePassX gestartet werden, man muss die URL kopieren und im geöffneten Browser einfügen. (Sicherheitsfeature)
wie kann ich den "englischen" JonDoBrowser" wieder entfernen
Das ist kein "JonDoBrowser" sondern ein ganz normaler (englischer) Firefox.

Der (deutsche) JonDoBrowser ist so richtig installiert.

bodman

Re: JonDoBrowser

Post by bodman » Fri Dec 20, 2013 22:45

cane wrote:
JonDoFox für Mac < als 10.9. Läuft dies auf 32-bit Rechnern?
Damit kann es wirklich keine Probleme geben. Sie brauchen einen aktuellen(!) Firefox, dann können Sie den JonDoFox installieren.

Das JonDoFox-Profil enthält keinen Binär-Code, das läuft auf allen Plattformen, für die es einen Firefox gibt.

Die Installation ist bei der legacy-Version für Mac < als 10.9. aber nicht sehr hübsch, Sie müssen ein Terminal öffnen und drei Befehle auf der Kommandozeile eintippen (Linux-like), siehe: https://www.anonym-surfen.de/help/insta ... l#macos108
Probleme gibt es auch hier, aber ich vermute sehr stark, dass es an mir liegt: Ich kann mit dem Terminal nicht umgehen, hatte bisher auch nie den Ehrgeiz, es zu lernen.

Habe den Firefox aktualisiert (26.0), das Archiv heruntergeladen und ausgepackt, die drei Befehle eingetippt und ... : "command not found" lautet jedes Mal die Antwort.

Ich brauche mal ein Wochenende "offline - time", danach sehe ich womöglich wieder klarer :?

xg27
Posts: 1111
Joined: Mon Jun 24, 2013 13:39

Re: JonDoBrowser

Post by xg27 » Sat Dec 21, 2013 10:47

bodman wrote:
Habe den Firefox aktualisiert (26.0), das Archiv heruntergeladen und ausgepackt, die drei Befehle eingetippt und ... : "command not found" lautet jedes Mal die Antwort.
Das kenne ich auch.....lol!

"command not found" kommt wenn:

1.) das aufgerufene Programm [command] ist nicht am Rechner installiert

2.) falsche Syntax: ein i-punkt falsch getippt und der Rechner versteht es nicht

3.) das aufgerufene Programm braucht admin-Rechte

In Ihrem Fall waere mein "guess" 3.) , vielleicht auch 2.)

wenn Sie einmal Musse haben probieren Sie einfach im Terminal

Code: Select all

man man
dort steht wie Sie sich mit den manual-pages zum jeweiligen command selbst helfen koennen; manchmal auch mit zusaetzlicher inet-suche.

Ihr Mac muesste eigentlich das root/su/sudo Konzept verstehen.Versuchen Sie:

Code: Select all

man su

Code: Select all

man sudo
Bei Syntax-rules sind Begriffe in eckigen Klammern [command] [Begriff] immer abstrakt gemeint; das heisst sie werden im praktischem Gebrauch durch die konkret gewuenschten Begriffe ersetzt und dann ohne Klammern.

Code: Select all

man [command]
sehr praktisch:

Code: Select all

man -k [command]
das listet alle man-pages auf die fuer den Begriff in Frage kommen koennten

Am Anfang verzweifelt man leicht dabei aber nach kurzer Zeit findet man sich besser zurecht als man vorher glaubte.

Dazu noch:
Gute manuals sind extrem praezise geschrieben und muessen auch praezise verstanden werden.
Bei mir geht das oft nicht beim ersten mal lesen.

bodman

Re: JonDoBrowser

Post by bodman » Sun Dec 22, 2013 19:15

@xg27: Danke für Hilfe und Rat!
1.) das aufgerufene Programm [command] ist nicht am Rechner installiert

2.) falsche Syntax: ein i-punkt falsch getippt und der Rechner versteht es nicht
Ich denke, ich kann diese beiden Punkte ausschließen: das Programm ist vorhanden (Paketinhalt überprüft), an der Rechtschreibung wird es auch nicht liegen, da ich mehrere Versuche unternommen habe. Ich werde aber verstärkt darauf achten.
3.) das aufgerufene Programm braucht admin-Rechte
Normalerweise öffnet sich in diesem Fall auf Mac-Rechnern ein entsprechendes Fenster. Ich habe es bisher noch nicht erlebt, dass dies unterbleibt sollten admin-Rechte von Nöten sein.

Ich habe eher den Verdacht, dass ich mit der Kommandozeile falsch umgehe. Ihre Angaben bzgl. der manual-pages haben mir da schon weiter geholfen. Ich werde aber wohl nicht darum herumkommen, meine zahlreichen aber selten genutzten Mac - Ratgeber aus dem Bücherregal zu ziehen :(


@cane

Einmal angenommen, es findet sich keine Lösung bzgl. der 32-bit Version des JonDoBrowser und ich bekomme die JonDoFox-Version für Mac > als 10.9 ans Laufen: Ist es dann jedes Mal notwendig, das Profil über das Terminal zu starten oder ist letztere nur für die Installation erforderlich?

cane

Re: JonDoBrowser

Post by cane » Thu Dec 26, 2013 12:35

Ist es dann jedes Mal notwendig, das Profil über das Terminal zu starten oder ist letztere nur für die Installation erforderlich?
Nein, eigentlich sollte Firefox bei jedem Start fragen, welches Profil verwendet werden soll.

Screenshot habe ich hier gefunden: http://www.privacy-handbuch.de/handbuch_23b.htm

Wenn Firefox nicht fragt, kann man ihn einmal im Terminal mit der Option -P starten und im Profilmanager die Option "Beim Starten nicht nachfragen" deaktivieren. (Sollte eigentlich die Installation so konfigurieren, wenn man das legacy-Paket für MacOS < 10.9 verwendet).

bodman

Re: JonDoBrowser

Post by bodman » Fri Dec 27, 2013 8:50

Nein, eigentlich sollte Firefox bei jedem Start fragen, welches Profil verwendet werden soll.
Gut zu wissen, so hatte ich es mir erhofft. Jetzt muss ich das JonDoFox-Profil für Mac > als 10.9 nur noch ans Laufen bekommen :roll: Mal schauen, vielleicht während der noch kommenden Feiertage.

disposab
Posts: 68
Joined: Tue Jun 18, 2013 21:39

Re: JonDoBrowser - ist auf engl nach update eines addons

Post by disposab » Thu Jan 02, 2014 16:20

hallo,

fiel mir just auf:
Update eines addons gemacht, Neustart, Jondobrowser ist auf englisch:
=> bildchen
Muss geschlossen werden + erneuter Neustart, dann wieder auf dt.
Hat das einen tieferen Sinn?

cane

Re: JonDoBrowser

Post by cane » Fri Jan 03, 2014 9:32

Update eines addons gemacht, Neustart, Jondobrowser ist auf englisch:
Das ist eher ein Problem im Firefox Code als im JonDoBrowser.

Wenn der deutsche JonDoBrowser normal gestartet wird, dann wird der Parameter "-UILocale de" übergeben. Es ist bei jedem OS ein bischen anders, wie der Parameter in das Start-Kommando rein kommt, aber damit wird die deutsche Oberfläche aktiviert.

Beim Restart aus der Add-on Verwaltung heraus wird der Parameter nicht übergeben und damit bleibt der FF bei "en-US". Auch sicherheitsrelevante Start-Parameter werden nicht mehr übernommen - sehr ärgerlich.

Früher konnte Firefox das besser, das Problem ist meiner Meinung nach erst mit FF 24 aufgetreten.

Also: Statt Restart aus der Add-on Verwaltung kann man den FF beenden und dann normal neu starten.

Post Reply