update auf JonDoFox-addon 0.5.1 ging wohl in die Hose

Wenn mal was nicht funktioniert...
Post Reply
disposab
Posts: 68
Joined: Tue Jun 18, 2013 21:39

update auf JonDoFox-addon 0.5.1 ging wohl in die Hose

Post by disposab » Fri Dec 27, 2013 9:30

Folgendes passierte (JonDoBrowser 0.12 sowohl unter linux-ubu12.04 als auch win-7):
update des addons durchgeführt von 0.5 auf 0.51, neu gestartet, Einstellungsmöglichkeit (proxywechsel) plötzlich verschwunden (addon-Leiste) bzw. Fehlermeldung wenn auf extras/addons/einstellungen geklickt.
siehe Schirmschuss:
huch

Da ist wohl falsch gebastelt worden?
Testet ihr das eig nicht? Bin leicht verwundert. Und hab die v0.5 wieder zurückgespielt, weil 0.51 nicht verwendbar ist.
JonDoFox übrigens gleich.

cane

Re: update auf JonDoFox-addon 0.5.1 ging wohl in die Hose

Post by cane » Fri Dec 27, 2013 13:35

Ein Bugfix Version 0.5.2 ist online.

Der Fehler in der deutschen Übersetzung hatte auf meinen beiden Testsystemen keine Auswirkung, da dort eine Zeichenkodierung verwendet wird, die auch mit einem "ü" und einem "Ä" in Hilfetexten zurechtkommt. (Man lernt immer wieder etwas dazu.)

blympson
Posts: 116
Joined: Thu Nov 15, 2012 18:48

update auf JonDoFox-addon 0.5.7

Post by blympson » Thu Feb 13, 2014 10:41

Hallo,
Nach einspielen des JdF-2901 und einem späteren aktualisieren wurde das JdF-addon auf die Version 0.5.7, noscript auf 2.6.8.14 angehoben. Nach Neustart war dann dummerweise die Option "Einstellungen" bei noscript auf englisch. Was so wahrscheinlich nicht sein soll(te)?
Liegt nachstellbar am JdF-addon 0.5.7., bei v056 bleibts auf dt.
mit JdF 0.5.6:
056
nach update 0.5.7:
057

Vermutlich liegts daran, dass die "Sprache" von v057 jetzt engl. ist, 056 war dt., fehlt die Übersetzung?

blympson
Posts: 116
Joined: Thu Nov 15, 2012 18:48

Re: JonDoFox-addon 0.5.7 - anscheinend falsche/fehlende Spra

Post by blympson » Fri Feb 14, 2014 10:24

Pfingschten, äh Sprachverwirrung die zwoote:
Jdf-addon 0.5.7 sorgt nach wie vor für verstellte/fehlende Sprachen, und zwar beim addon selbst (meldet sich nach update/neustart) auf engl., als auch bei noscript. Beide sind in den Konfig-Menüs englisch.

Dies ist reproduzierbar aufs Jdf-addon-0.5.7 zurückzuführen. Spielt man das vorige Jdf-addon-0.5.6 zurück, bleibt zunächst alles auf engl., spielt man dazu noch die vorige prefs.js (z.B. aus einem unveränderten JdF-Profil 2901) zurück, sind beide addons in den Konfig-Menüs wieder auf deutsch. Wie es sein soll.
Also der Wirrwarr wird verursacht durch eine Kombi aus Jdf-0.5.7 und davon wohl verursachten "falschen" Einträgen in der pref.js.

Nochmal: Woran liegts, fehlt die Übersetzung?

JonDoBrowser 0.13 zeigt derlei nicht, hat aber dafür noch ein anderes Addon im Gepäck: 0.5.7.1, das beim JdF a) nicht angeboten wird, b) die beschriebene Problematik nicht behebt...

cane

Re: update auf JonDoFox-addon 0.5.1 ging wohl in die Hose

Post by cane » Fri Feb 14, 2014 10:43

Nochmal: Woran liegts, fehlt die Übersetzung?
Ich weiß es noch nicht. Das Problem tritt nur in der Kombination "JonDoFox-XPI 0.5.7 + NoScript 2.6.8.14" auf. Mit "NoScript 2.6.8.13 + JDF-XPI 0.5.7" gibt es diese Probleme nicht. (Das JDF-Profil zum Download enthält Noscript 2.6.8.13)

Es gibt keinen Fehler in der Übersetzung, es wird kein Fehler gemeldet und ich habe es inzwischen mehrfach vorwärts und rückwärts abgesucht.
JonDoBrowser 0.13 zeigt derlei nicht, hat aber dafür noch ein anderes Addon im Gepäck: 0.5.7.1
0.5.7.1 setzt nur die Version des aktuellen JonDoBrowser auf 0.13, um den Update-Hinweis auszulösen, ist ansonsten identisch mit 0.5.7.

blympson
Posts: 116
Joined: Thu Nov 15, 2012 18:48

Re: update auf JonDoFox-addon 0.5.1 ging wohl in die Hose

Post by blympson » Sat Feb 15, 2014 15:39

cane wrote:Das Problem tritt nur in der Kombination "JonDoFox-XPI 0.5.7 + NoScript 2.6.8.14" auf. Mit "NoScript 2.6.8.13 + JDF-XPI 0.5.7" gibt es diese Probleme nicht...
Ist hier definitiv nicht so (probiert 2x win7-8, 1x linux mint) und wird nicht vom neuen noscript-addon 26814 ausgelöst, vgl. Bild. Deswegen ja auch oben meine Anmerkung ('Dies ist reproduzierbar aufs Jdf-addon-0.5.7 (+ irgendwelche Einträge in der prefs.js) zurückzuführen.').

Sowie Behebung:
Spielt man das vorige Jdf-addon-0.5.6 zurück, bleibt zunächst alles auf engl., spielt man dazu noch die vorige prefs.js (z.B. aus einem unveränderten JdF-Profil 2901) zurück, sind beide addons in den Konfig-Menüs wieder auf deutsch.

Post Reply